バージョンは同じにした方がいいのです - 専門家回答 - 専門家プロファイル

専門家の皆様へ 専門家プロファイルでは、さまざまなジャンルの専門家を募集しています。
出展をご検討の方はお気軽にご請求ください。

注目のQ&AランキングRSS

対象:システム開発・導入

井上 みやび子

井上 みやび子
Webエンジニア

- good

バージョンは同じにした方がいいのです

2008/10/20 20:57
(
4.0
)

こんにちは。ウェブウェア・オルグの井上と申します。
XAMPP や MovableType はあまり詳しくないのですが、開発環境の準備に関する一般的な観点からご回答しますね。

*MovableType の要件 ×「開発」の内容に揃える

基本的には、開発環境は本番環境と同じにしないとどこで不具合が出ても不思議はありません。
と言ってもこの場合全てを揃えるのは難しそうですので、

・行おうとしてる「開発」に関わる部分を優先して揃え
・MovableType がサーバと同様に動作する事を確認する

という手順が良いかと思います。

つまり、

1.
PHP で何らかのカスタマイズをしようとしているのであれば PHP のバージョンを優先して XAMPP を選び

2.
その上で MovableType をインストール

3.
サーバから MovableType の登録データをエクスポートの上、開発環境にインポート

の順で作業して、サーバ上と同じように MovableType が動作する事が確認できたらその上で開発を進めていくのが良いかと思います。

また、本格的に開発を始める前に開発環境で小さな変更を行いサーバ上で期待通り動作するかを確かめてみて下さい。
開発環境の変更をサーバに反映する練習にもなりますのでよいと思います。

評価・お礼

hoihoi さん

早速のご回答ありがとうございます。
まだ本格的にシステム開発をするという程のレベルでもないですので、開発環境を勉強するという事でいろいろチャレンジしてみたいと思います。

(現在のポイント:-pt このQ&Aは、役に立った!

この回答の相談

XAMPPのバージョンについて

法人・ビジネス システム開発・導入 2008/10/20 19:42

現在ロリポップサーバというレンタルサーバにて、サイトを運営しております。MovableTypeをサーバにインストールし、サイト管理を行っています。拡張子は全てPHPにしており、現在PHPやDBについて勉強し、い… [続きを読む]

hoihoiさん (東京都/34歳/男性)

このQ&Aの回答

xamppの使用方法 上原 正吉(Webプロデューサー) 2008/10/21 09:38
MovableTypeは4.1です。 2008/10/21 16:56

このQ&Aに類似したQ&A

SSL導入レンタルサーバーの事で悩んでおります。 DELTAさん  2009-03-17 11:21 回答2件
システム開発現場で使っているツールが知りたい! 日々勉強さん  2009-08-26 15:47 回答1件
WEBシステムの瑕疵担保期間 norikominekoさん  2009-03-13 11:08 回答3件
MySQLを知らないスタッフが操作できるインターフェース 専門家プロファイルさん  2008-01-18 10:25 回答3件
ショッピングサイトの構築 たっつんさん  2007-09-13 02:01 回答1件